The spwr Ethernet driver is a multi-threaded, loadable, clonable, STREAMS hardware driver supporting the connectionless Data Link Provider Interface, dlpi(7P), over SMC EtherPower II 10/100 controllers. Multiple EtherPower II controllers installed within the system are supported by the driver. The spwr driver provides basic support for the SMC EtherPower II hardware. Functions include chip initialization, frame transmit and receive, multicast support, and error recovery and reporting.
The cloning character-special device /dev/spwr is used to access all SMC EtherPower II devices installed within the system.
The spwr driver is dependent on /kernel/misc/gld, a loadable kernel module that provides the spwr driver with the DLPI and STREAMS functionality required of a LAN driver. See gld(7d) for more details on the primitives supported by the driver.
The values returned by the driver in the DL_INFO_ACK primitive in response to the DL_INFO_REQ from the user are as follows:
• The maximum SDU is 1500 ( ETHERMTU).
• The minimum SDU is 0. The spwr driver will pad to the mandatory 60-octet minimum packet size.
• The DLSAP address length is 8.
• The MAC type is DL_ETHER.
• The SAP length value is -2, meaning the physical address component is followed immediately by a 2-byte SAP component within the DLSAP address.
• The broadcast address value is Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
/dev/spwr Character special device.
/kernel/drv/spwr.conf Driver configuration file
See attributes(5) for descriptions of the following attributes:
attributes(5), dlpi(7P), gld(7D)