statd is an intermediate version of the status monitor. It interacts with lockd(1M) to provide the crash and recovery functions for the locking services on NFS. statd keeps track of the clients with processes which hold locks on a server. When the server reboots after a crash, statd sends a message to the statd on each client indicating that the server has rebooted. The client statd processes then inform the lockd on the client that the server has rebooted. The client lockd then attempts to reclaim the lock(s) from the server.
statd on the client host also informs the statd on the server(s) holding locks for the client when the client has rebooted. In this case, the statd on the server informs its lockd that all locks held by the rebooting client should be released, allowing other processes to lock those files.
lockd is started by automountd(1M), mount_nfs(1M), and share(1M) if NFS automounts are needed.
/var/statmon/sm lists hosts and network addresses to be contacted after a reboot
/var/statmon/sm.bak lists hosts and network addresses that could not be contacted after last reboot
/var/statmon/state includes a number which changes during a reboot
/usr/include/rpcsvc/sm_inter.x contains the rpcgen source code for the interface services provided by the statd daemon.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
svcs(1), automountd(1M), lockd(1M), mount_nfs(1M), share(1M), svcadm(1M), attributes(5), smf(5)
System Administration Guide: IP Services
The crash of a server is only detected upon its recovery.
The statd service is managed by the service management facility, smf(5), under the service identifier:
Administrative actions on this service, such as enabling, disabling, or requesting restart, can be performed using svcadm(1M). The service's status can be queried using the svcs(1) command.
If it is disabled, it will be enabled by mount_nfs(1M), share_nfs(1M), and automountd(1M) unless its application/auto_enable property is set to false.