rpc.bootparamd is a server process that provides information from a bootparams database to diskless clients at boot time. See bootparams(4)
The source for the bootparams database is determined by the nsswitch.conf(4) file (on the machine running the rpc.bootparamd process).
The following options are supported:
-d Display debugging information.
/etc/bootparams boot parameter data base
/etc/nsswitch.conf configuration file for the name-service switch
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
svcs(1),svcadm(1M), bootparams(4), nsswitch.conf(4), attributes(5), smf(5)
A diskless client requires service from at least one rpc.bootparamd process running on a server that is on the same IP subnetwork as the diskless client.
Some routines that compare hostnames use case-sensitive string comparisons; some do not. If an incoming request fails, verify that the case of the hostname in the file to be parsed matches the case of the hostname called for, and attempt the request again.
The rpc.bootparamd service is managed by the service management facility, smf(5), under the service identifier:
Administrative actions on this service, such as enabling, disabling, or requesting restart, can be performed using svcadm(1M). The service's status can be queried using the svcs(1) command.