/usr/sbin/reboot [-dlnq] [boot_arguments]
The reboot utility restarts the kernel. The kernel is loaded into memory by the PROM monitor, which transfers control to the loaded kernel.
Although reboot can be run by the super-user at any time, shutdown(1M) is normally used first to warn all users logged in of the impending loss of service. See shutdown(1M) for details.
The reboot utility performs a sync(1M) operation on the disks, and then a multi-user reboot is initiated. See init(1M) for details. On x86 systems, reboot may also update the boot archive as needed to ensure a successful reboot.
The reboot utility normally logs the reboot to the system log daemon, syslogd(1M), and places a shutdown record in the login accounting file /var/adm/wtmpx. These actions are inhibited if the -n or -q options are present.
Normally, the system reboots itself at power-up or after crashes.
The following options are supported:
-d Force a system crash dump before rebooting. See dumpadm(1M) for information on configuring system crash dumps.
-l Suppress sending a message to the system log daemon, syslogd(1M) about who executed reboot.
-n Avoid calling sync(2) and do not log the reboot to syslogd(1M) or to /var/adm/wtmpx. The kernel still attempts to sync filesystems prior to reboot, except if the -d option is also present. If -d is used with -n, the kernel does not attempt to sync filesystems.
-q Quick. Reboot quickly and ungracefully, without shutting down running processes first.
The following operands are supported:
boot_arguments An optional boot_arguments specifies arguments to the uadmin(2) function that are passed to the boot program and kernel upon restart. The form and list of arguments is described in the boot(1M) and kernel(1M) man pages.. If the arguments are specified, whitespace between them is replaced by single spaces unless the whitespace is quoted for the shell. If the boot_arguments begin with a hyphen, they must be preceded by the -- delimiter (two hyphens) to denote the end of the reboot argument list.
Example 1: Passing the -r and -v Arguments to boot
In the following example, the delimiter -- (two hyphens) must be used to separate the options of reboot from the arguments of boot(1M).
example# reboot -dl -- -rv
Example 2: Rebooting Using a Specific Disk and Kernel
The following example reboots using a specific disk and kernel.
example# reboot disk1 kernel.test/unix
/var/adm/wtmpx login accounting file
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
mdb(1), boot(1M), dumpadm(1M), fsck(1M), halt(1M), init(1M), kernel(1M), shutdown(1M), sync(1M), syslogd(1M), sync(2), uadmin(2), reboot(3C), attributes(5)
The reboot utility does not execute the scripts in /etc/rcnum.d or execute shutdown actions in inittab(4). To ensure a complete shutdown of system services, use shutdown(1M) or init(1M) to reboot a Solaris system.