Man page of praudit
Section: System Administration Commands (1M)
Updated: 26 Jul 2009
Return to Main Contents
praudit - print contents of an audit trail file
praudit [-lrsx] [-ddel] [filename]...
praudit reads the listed filenames (or standard input, if no filename is specified) and interprets the data as audit trail records as defined in audit.log(4). By default, times, user and group IDs (UIDs and GIDs, respectively) are converted to their ASCII representation. Record type and event fields are converted to their ASCII representation. A maximum of 100 audit files can be specified on the command line.
The following options are supported:
Use del as the field delimiter instead of the default delimiter, which is the comma. If del has special meaning for the shell, it must be quoted. The maximum size of a delimiter is three characters. The delimiter is not meaningful and is not used when the -x option is specified.
Print one line per record.
Print records in their raw form. Times, UIDs, GIDs, record types, and events are displayed as integers. This option is useful when naming services are offline. The -r option and the -s option are exclusive. If both are used, a format usage error message is output.
Display records in their short form. Numeric fields' ASCII equivalents are looked up by means of the sources specified in the /etc/nsswitch.conf file (see nsswitch.conf(4)). All numeric fields are converted to ASCII and then displayed. The short ASCII representations for the record type and event fields are used. This option and the -r option are exclusive. If both are used, a format usage error message is output.
Print records in XML form. Tags are included in the output to identify tokens and fields within tokens. Output begins with a valid XML prolog, which includes identification of the DTD which can be used to parse the XML.
Audit event definition and class mappings.
Audit class definitions.
Directory containing the verisioned DTD file referenced in XML output, for example, adt_record.dtd.1.
Directory containing the versioned XSL file referenced in XML output, for example, adt_record.xsl.1.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
The command stability is evolving. The output format is unstable.
bsmconv(1M), getent(1M), audit(2), getauditflags(3BSM), getpwuid(3C), gethostbyaddr(3NSL), ethers(3SOCKET), getipnodebyaddr(3SOCKET), audit.log(4), audit_class(4), audit_event(4), group(4), nsswitch.conf(4), passwd(4), attributes(5)
See the section on Solaris Auditing in System Administration Guide: Security Services.
This functionality is available only if the Solaris Auditing feature has been enabled. See bsmconv(1M) for more information.
- SEE ALSO
This document was created by
using the manual pages.
Time: 02:37:09 GMT, October 02, 2010