Man page of named-checkzone
Section: System Administration Commands (1M)
Updated: 20 Mar 2007
Return to Main Contents
named-checkzone - zone file validity checking tool
named-checkzone [-djqv] [-c class] [-k mode] [-n mode]
[-o filename] [-t directory] [-w directory] [-D]
The named-checkzone utility checks the syntax and integrity of a zone file. It performs the same checks as named(1M) does when loading
a zone. The named-checkzone utility is useful for checking zone files before configuring them into a name server.
The following options are supported:
Specify the class of the zone. If not specified, "IN" is assumed.
Dump zone file in canonical format.
Perform "check-name" checks with the specified failure mode. Possible modes are fail, warn (the default) and ignore.
Read the journal, if it exists, when loading the zone file.
Specify whether NS records should be checked to see if they are addresses. Possible modes are fail, warn (the default) and ignore.
Write zone output to filename.
Run in quiet mode, reporting only the exit status.
chroot to directory so that include directives in the configuration file are processed as if run by a similarly chrooted named.
Print the version of the named-checkzone program and exit.
chdir to directory so that relative filenames in master file $INCLUDE directives work. This is similar to the directory clause in named.conf.
The following operands are supported:
The name of the zone file.
The domain name of the zone being checked.
No errors were detected.
An error was detected.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
BIND 9 Administrator Reference Manual, available on the ISC web site.
Source for BIND9 is available in the SUNWbind9S package.
- EXIT STATUS
- SEE ALSO
This document was created by
using the manual pages.
Time: 02:37:09 GMT, October 02, 2010