/usr/lib/mail.local [-f sender] [-d] recipient
mail.local reads the standard input up to an end-of-file and appends it to each user's mail file (mailbox). This program is intended to be used by sendmail(1M) as a mail delivery agent for local mail. It is not a user interface agent.
Messages are appended to the user's mail file in the /var/mail directory. The user must be a valid user name.
Each delivered mail message in the mailbox is preceded by a "Unix From line" with the following format:
The sender_address is extracted from the SMTP envelope address (the envelope address is specified with the -f option).
A trailing blank line is also added to the end of each message.
The mail files are locked with a .lock file while mail is appended.
The mail files are created with mode 660, owner is set to recipient, and group is set to mail. If the ``biff'' service is returned by getservbyname(3SOCKET), the biff server is notified of delivered mail. This program also computes the Content-Length: header which will be used by the mailbox reader to mark the message boundary.
The following options are supported:
-f sender Specifies the "envelope from address" of the message. This flag is technically optional, but should be used.
-d Specifies the recipient of the message. This flag is also optional and is supported here for backward compatibility. That is, mail.local recipient is the same as mail.local -d recipient.
-l Turn on LMTP mode.
-r from Specify the sender's name (for backward compatibility).
-7 Do not advertise 8BITMIME support in LMTP mode.
-b Return a permanent error instead of a temporary error if a mailbox exceeds quota.
The following operand is supported:
recipient The recipient of the mail message.
TZ Used to set the appropriate time zone on the timestamp.
The following exit values are returned:
0 Successful operation.
>0 An error occurred.
/tmp/local.XXXXXX temporary files
/tmp/lochd.XXXXXX temporary files
/var/mail/user_name user's mail file
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
mail(1), comsat(1M), sendmail(1M), getservbyname(3SOCKET), attributes(5)