lpget [-k key] [destination... | list]
The lpget utility reads printing configuration information from the configuration databases in $HOME/.printers, /etc/printers.conf, printers.conf.byname, and printers.org_dir printer. This information, called a configuration report, is displayed to the standard output. See printers(4) and printers.conf(4) for information about the printer configuration databases.
lpget displays a configuration report for all keys for the specified destination or destinations by default. Use the -k option to display a configuration report for specific keys. Use the list operand to display a configuration report for all configured destinations.
The following option is supported:
-k key Displays a configuration report for key. See printers.conf(4) for information about specifying key.
The following operands are supported:
destination Displays a configuration report for destination. Destination can be either a printer of a class of printers. See lpadmin(1M). Specify destination using atomic or POSIX-style (server:destination) names. See printers.conf (4) for information regarding the naming conventions for atomic names and standards(5) for information concerning POSIX.
list Displays a configuration report for all configured destinations.
Example 1: Displaying a Configuration Report for the bsdaddr Key
The following example displays a configuration report for the bsdaddr key for printer catalpa.
example% lpget -k bsdaddr catalpa
Example 2: A Configuration Report for all Keys for all Configured Destinations
The following example displays a configuration report for all keys for all configured destinations.
example% lpget list
The following exit values are returned:
0 Successful completion.
non-zero An error occurred.
/etc/printers.conf System printer configuration database.
$HOME/.printers User-configurable printer database.
printers.conf.byname NIS version of /etc/printers.conf.
printers.org_dir NIS+ version of /etc/printers.conf.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
ldap(1), lp(1), lpc(1B), lpq(1B), lpr(1B), lpstat(1), lpadmin (1M), lpset(1M), printers(4), printers.conf(4), attributes(5), standards(5)
System Administration Guide: Naming and Directory Services (DNS, NIS, and LDAP)
Be mindful of the following if the LDAP database is used as the name service. If the ldapclient(1M) server is a replica LDAP server, LDAP printer database updates may not appear immediately, as the replica server may not not have been updated by the master server and can be out of sync. For example, a printer that you deleted by using lpset(1M) may still appear in the printer list you display with lpget until the replica is updated from the master. Replica servers vary as to how often they are updated from the master. Refer to the System Administration Guide: Naming and Directory Services (DNS, NIS, and LDAP) for more information on LDAP replication.