installboot [-F zfs|ufs|hsfs] bootblk raw-disk-device
The boot(1M) program, ufsboot, is loaded from disk by the bootblock program which resides in the boot area of a disk partition. This program is filesystem-specific, and must match the type of filesystem on the disk to be booted.
The boot objects are platform-dependent and reside in the /usr/platform/platform-name/lib/fs/file-system directory. The platform name can be found using the -i option of uname(1). The filesystem type can be found using:
% fstyp raw-disk-device
The installboot utility is a SPARC only program. It is not supported on the x86 architecture. x86 users should use installgrub(1M) instead.
The following option is supported:
Example 1 Installing UFS Boot Block
To install a ufs boot block on slice 0 of target 0 on controller 1 of the platform where the command is being run, use:
# installboot /usr/platform/`uname -i`/lib/fs/ufs/bootblk \ /dev/rdsk/c1t0d0s0
Example 2 Installing ZFS Boot Block
To install a ZFS boot block on slice 0 of target 0 on controller 1 of the platform where the command is being run, use syntax such as the following:
# installboot -F zfs /usr/platform/`uname -i`/lib/fs/zfs/bootblk \ /dev/rdsk/c0t1d0s0
See attributes(5) for descriptions of the following attributes:
od(1), uname(1), boot(1M), fstyp(1M), init(1M), kadb(1M), kernel(1M), monitor(1M), reboot(1M), rpc.bootparamd(1M), init.d(4), attributes(5)
The installboot utility fails if the bootblk or openfirmware files do not exist or if the raw disk device is not a character device.