fpsd is a user-level daemon that periodically runs non-intrusive tests to validate proper functioning of FPU (Floating Point Unit) hardware in the system. A fault management action is initiated by means of fmd(1M), in case an error is detected by the test.
The following exit values are returned:
See attributes(5) for descriptions of the following attributes:
svcs(1), fmd(1M), svcadm(1M), svccfg(1M), attributes(5), smf(5)
The fpsd service is managed by the service management facility, smf(5), under the service identifier:
You can use svccfg(1M) to change the default fpsd behavior:
Property Name Type Description ------------- ---- ----------- config/exclude_cpus astring comma delimited list of CPU IDs to be excluded from proactive testing.
Administrative actions on this service, such as enabling, disabling, or requesting restart, can be performed using svcadm(1M). The service's status can be queried using the svcs(1) command.
Disabling the service can increase system's vulnerability to silent data corruption, if a fault were to develop in an FPU within the system.