/usr/sbin/bsmrecord [-d] [ [-a] | [-e string] | [-c class] | [-i id] | [-p programname] | [-s systemcall] | [-h]]
The bsmrecord utility displays the event ID, audit class and selection mask, and record format for audit record event types defined in audit_event(4). You can use bsmrecord to generate a list of all audit record formats, or to select audit record formats based on event class, event name, generating program name, system call name, or event ID.
There are two output formats. The default format is intended for display in a terminal window; the optional HTML format is intended for viewing with a web browser.
Tokens contained in square brackets ( [ ] ) are optional and might not be present in every record.
The following options are supported:
The -p and -s options are different names for the same thing and are mutually exclusive. The -a option is ignored if any of -c, -e, -i, -p, or -s are given. Combinations of -c, -e, -i, and either -p or -s are ANDed together.
Example 1 Displaying an Audit Record with a Specified Event ID
The following example shows how to display the contents of a specified audit record.
% bsmrecord -i 6152 terminal login program /usr/sbin/login see login(1) /usr/dt/bin/dtlogin See dtlogin event ID 6152 AUE_login class lo (0x00001000) header subject [text] error message return
Example 2 Displaying an Audit Record with an Event ID Label that Contains a Specified String
The following example shows how to display the contents of a audit record with an event ID label that contains the string login.
# bsmrecord -e login terminal login program /usr/sbin/login see login(1) /usr/dt/bin/dtlogin See dtlogin event ID 6152 AUE_login class lo (0x00001000) header subject [text] error message return rlogin program /usr/sbin/login see login(1) - rlogin event ID 6155 AUE_rlogin class lo (0x00001000) header subject [text] error message return
See attributes(5) for descriptions of the following attributes:
auditconfig(1M), praudit(1M), audit.log(4), audit_class(4), audit_event(4), attributes(5)
See the section on Solaris Auditing in System Administration Guide: Security Services.
If unable to read either of its input files or to write its output file, bsmrecord shows the name of the file on which it failed and exits with a non-zero return.
If no options are provided, if an invalid option is provided, or if both -s and -p are provided, an error message is displayed and bsmrecord displays a usage message then exits with a non-zero return.
This command is Obsolete and may be removed and replaced with equivalent functionality in a future release of Solaris.
If /etc/security/audit_event has been modified to add user-defined audit events, bsmrecord displays the record format as undefined.
The audit records displayed by bsmrecord are the core of the record that can be produced. Various audit policies and optional tokens, such as those shown below, might also be present.
The following is a list of praudit(1M) token names with their descriptions.