Man page of net_protocol_release
Section: Kernel Functions for Drivers (9F)
Updated: 1 May 2008
Return to Main Contents
net_protocol_release - indicate that a reference to a network protocol is no longer required
int net_protocol_release(net_data_t *net);
Solaris DDI specific (Solaris DDI).
value returned from a successful call to net_protocol_lookup(9F).
The net_protocol_release() function indicates to the network information framework that the caller is no longer interested in any knowledge about the network protocol to which the parameter being passed through applies.
The net_protocol_release() function returns:
The value passed in is unknown to this framework.
Unsuccessful because this function has been called too many times.
The net_protocol_release() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
net_protocol_lookup(9F), net_protocol_walk(9F), attributes(5)
- INTERFACE LEVEL
- RETURN VALUES
- SEE ALSO
This document was created by
using the manual pages.
Time: 02:39:43 GMT, October 02, 2010