The ntxn 10/1 Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on NetXen 10/1 Gigabit Ethernet controllers.
The ntxn driver functions include chip initialization, frames transmit and receive, promiscuous and multicast support, TCP and UDP checksum off-load (IPv4) and 9600 bytes jumbo frame.
The ntxn driver and hardware support the 10GBASE CX4, 10GBASE-SR/W, LR/W, and 10/100/1000BASE-T physical layers.
The cloning character-special device, /dev/ntxn, is used to access all NetXen devices installed within the system.
The ntxn driver is managed by the dladm(1M) command line utility, which allows VLANs to be defined on top of ntxn instances and for ntxn instances to be aggregated. See dladm(1M) for more details.
The values returned by the driver in the DL_INFO_ACK primitive in response to your DL_INFO_REQ are:
By default, the ntxn driver works without any configuration file.
See attributes(5) for descriptions of the following attributes:
dladm(1M), ndd(1M), netstat(1M), driver.conf(4), attributes(5), streamio(7I), dlpi(7P)
Writing Device Drivers
STREAMS Programming Guide
Network Interfaces Programmer's Guide