The bbc_beep driver generates beeps on platforms (including Sun Blade 1000) that use BBC-based registers and USB keyboards. When the KIOCCMD ioctl is issued to the USB keyboard module (see usbkbm(7M)) with command KBD_CMD_BELL/KBD_CMD_NOBELL, usbkbm(7M) passes the request to the bbc_beep driver to turn the beep on and off, respectively.
64-bit ELF kernel driver
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
kbd(1), attributes(5), grbeep(7D), kb(7M), usbkbm(7M)
Writing Device Drivers