/usr/lib/dmi/snmpXdmid -s hostname [-h] [-c config-dir] [-d debug-level]
The snmpXdmid utility is a subagent in the Solstice Enterprise Agent Desktop Management Interface package. It maps the SNMP requests forwarded by the Master Agent ( snmpdx(1M)) into one or more equivalent DMI requests. Further, it remaps the DMI response into SNMP response back to snmpdx. By default, snmpXdmid also forwards the DMI indications as SNMP traps to snmpdx. The feature is configurable and can be disabled by setting TRAP_FORWARD_TO_MAGENT=0 in the snmpXdmid configuration file, snmpXdmid.conf.
This subagent runs as a daemon in the system. The subagent uses a set of .MAP files located in /var/dmi/map to map the SNMP Object Identifier (OID) into a corresponding DMI component. The map files are generated using the MIF-to-MIB utility, miftomib. They are read by snmpXdmid when a corresponding MIF file gets registered with the DMI Service Provider ( dmispd(1M)).
Note - The SMA (Systems Management Agent) is the default SNMP agent in Solaris. See netsnmp(5). snmpdx is Obsolete and may not be supported in a future release of Solaris.
The snmpXdmid.conf file is used for configuration information. Each entry in the file consists of a keyword followed by an equal sign (=), followed by a parameter string. The keyword must begin in the first position. A line beginning with a pound sign (#) is treated as a comment and the subsequent characters on that line are ignored. The keywords currently supported are:
Indication subscription expiration, warning time.
Indication subscription expiration timestamp.
DMISP retries before dropping indication due to comm errors.
0 Drop indication at the subagent level.
non-zero Forward indications as SNMP traps to snmpdx.
By default, the configuration file snmpXdmid.conf is located in the /etc/dmi/conf directory. You can specify an alternative directory with the -c option.
The following options are supported:
-c config-dir Specify the directory where snmpXdmid.conf file is located.
-d debug-level Debug. Levels from 1 to 5 are supported, giving various levels of debug information.
-h Help. Print the command line usage.
-s hostname Specify the host on which dmispd is running.
/etc/dmi/conf/snmpXdmid.conf DMI mapper configuration file
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
dmispd(1M), snmpdx(1M), attributes(5), netsnmp(5)