svccfg svc:/application/management/wbem start | stop
The init.wbem utility is run automatically during installation, each time the system is rebooted, and by means of the svccfg(1M) command. This method manipulates the CIM Object Manager (CIMOM) and the Solaris Management Console server, both of which run combined in a single process. init.wbem can be used to start, stop, or retrieve status from the server.
The CIM Object Manager manages CIM objects on a WBEM-enabled system. A CIM object is a computer representation, or model, of a managed resource, such as a printer, disk drive, or CPU. CIM objects are stored internally as Java classes.
When a WBEM client application accesses information about a CIM object, the CIM Object Manager contacts either the appropriate provider for that object or the CIM Object Manager Repository. Providers are classes that communicate with managed objects to access data.
When a WBEM client application requests data from a managed resource that is not available from the CIM Object Manager Repository, the CIM Object Manager forwards the request to the provider for that managed resource. The provider dynamically retrieves the information.
At startup, the CIM Object Manager performs the following functions:
During normal operations, the CIM Object Manager performs the following functions:
A WBEM client application contacts the CIM Object Manager to establish a connection when it needs to perform WBEM operations, such as creating a CIM class or updating a CIM instance. When a WBEM client application connects to a CIM Object Manager, it gets a reference to the CIM Object Manager, which it then uses to request services and operations.
The Solaris Management Console server is the back end to the front end console, smc(1M). It provides tools for the console to download and performs common services for the console and its tools to use, such as authentication, authorization, logging, messaging, and persistence.
The init.wbem script is installed in the /etc/init.d directory.
The init.wbem function is implemented as a service management facility (SMF) method and is controlled by means of the svcadm(1M) command using the fault management resource identifier (FMRI) svc:/application/management/wbem.
The following options are supported through svcadm(1M):
The SMF property options/tcp_listen is used to control whether CIMOM and the Solaris Management console server will respond to requests from remote systems.
svc:/application/management/wbem/options/tcp_listen = true
...allows remote access and false disallows remote access. false is the default value.
Example 1 Allowing Access to Remote Systems
The following commands enable CIMOM and the Solaris Management Console server to allow access from remote systems.
# svccfg -s \ svc:/application/management/wbem setprop options/tcp_listen = true # svcadm refresh svc:/application/management/wbem
When the init.wbem script is invoked by SMF, it does not run the CIMOM and Solaris Management Console server directly. The server process is in Java and is too heavyweight to be run immediately at system boot time. Instead, three lightweight processes listen on three different ports that the CIMOM and the Solaris Management Console server normally use. This acts similarly to inetd(1M).
Because Java programs cannot inherit file descriptors as other programs can, there is a small time period from when the first connection is made until the server is fully operational where client connections may be dropped. WBEM clients are immune to this, as they will retry until the server comes online. Solaris Management Console clients are not immune, and it may be necessary to manually reconnect, though this should not happen in the common case.
See attributes(5) for descriptions of the following attributes:
inetd(1M), mofcomp(1M), smc(1M), smcconf(1M), svccfg(1M), svcadm(1M), wbemadmin(1M), wbemlogviewer(1M), attributes(5), smf(5)