/sbin/fiocompress -c [-m] [-b block_size] input_file output_file
/sbin/fiocompress -d input_file output_file
The fiocompress utility is a file compression tool that works together with the dcfs(7FS) file system to perform per-file compression. You can use fiocompress to decompress a compressed file or mark a compressed file as compressed, causing automatic decompression on read. The primary use of fiocompress is to compress files in the boot archive.
Note that this utility is not a Committed interface. See attributes(5).
The following options are supported:
See attributes(5) for descriptions of the following attributes:
boot(1M), bootadm(1M), dcfs(7FS), ufs(7FS), attributes(5)
This compression/decompression utility works only with files stored in a UFS file system.
There is no obvious way to determine whether a given file is compressed, other than copying the file and comparing the number of disk blocks of the copy against the original.