The audit daemon, auditd, controls the generation and location of audit trail files and the generation of syslog messages based on the definitions in audit_control(4). If auditing is enabled, auditd reads the audit_control(4) file to do the following:
audit(1M) is used to control auditd. It can cause auditd to:
The audit daemon invokes the program audit_warn(1M) under the following conditions with the indicated options:
audit_warn soft pathname
audit_warn hard pathname
audit_warn allhard count
The audit daemon will hang in a sleep loop until this file is fixed.
See attributes(5) for descriptions of the following attributes:
audit(1M), audit_warn(1M), bsmconv(1M), praudit(1M), auditon(2), auditsvc(2), audit.log(4), audit_control(4), audit_data(4), attributes(5)
See the section on Solaris Auditing in System Administration Guide: Security Services.
The functionality described in this man page is available only if the Solaris Auditing feature has been enabled. See bsmconv(1M) for more information.
auditd is loaded in the global zone at boot time if auditing is enabled. See bsmconv(1M).
If the audit policy perzone is set, auditd runs in each zone, starting automatically when the local zone boots. If a zone is running when the perzone policy is set, auditing must be started manually in local zones. It is not necessary to reboot the system or the local zone to start auditing in a local zone. auditd can be started with "/usr/sbin/audit -s" and will start automatically with future boots of the zone.
When auditd runs in a local zone, the configuration is taken from the local zone's /etc/security directory's files: audit_control, audit_class, audit_user, audit_startup, and audit_event.
Configuration changes do not affect audit sessions that are currently running, as the changes do not modify a process's preselection mask. To change the preselection mask on a running process, use the -setpmask option of the auditconfig command (see auditconfig(1M)). If the user logs out and logs back in, the new configuration changes will be reflected in the next audit session.